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SAS Intermediate Training 
 

The SAS Intermediate Training course is intended for experienced users of SAS Web Report Studio and those 
who would like to create new or customize existing reports. We will cover how to create a new section report 
to add to the Table of Contents, and will cover adding Titles, Headers, Footers, Totals, Formatting, and Group 
Breaks. 

Refresher 

 

A. Quick link back to the Portal allows you to easily open a new report or reopen the current report when 
needed. 

B. The File/Edit/View/Data menu and the icons that follow contain various commands and SAS settings. 

C. The Table of Contents window in the left-hand panel contains the list of sub-reports (called “sections”) 
that are contained in the overall report (i.e., the CFR). The Options drop down menu offers tools to 
manage your sections. When using Group Breaks, this window will expand to allow selection of those 
defined break columns. 

D. The Section Data window in the left-hand panel shows the Information Map that is selected and will 
list the fields that have been identified as available for use in the current report. SAS Data is refreshed 
each night and combines data from several systems including PeopleSoft (financial data and ePro), 
OwlPay, Concur (Travel) and PCard.   

E. The Edit Tab is the report design workspace for creating or modifying a report. 
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F. The View Tab shows the report populated with the data from the Information map. 

G. The Glossary of Terms describes the columns in the reports. 

H. Log Off to close SAS and exit properly. 
 

Open the CFR  
 
Add a New Section Report in the Table of Contents 
 

1. Click: The Edit Tab 

 
 

2. Click: The drop down under the Table of Contents and choose “Insert a New Section…” 
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3. Enter a New Section Name: Class Report 
4. Choose: “Copy data from” and select the report which contains the data you would like to use in your 

new report. 
5. Leave the Header and Footer blank, we will add those later. 
6. Click: OK 

 

 Information Maps - notice that the Section Data panel on the left side of the screen has been 
prepopulated with the dataset that you chose by copying the information map from the selected report, in 
the above step “4.”. The information map holds the data that populates the report and comes in two 
styles.  One is a based on a “cube” which is similar in concept to an Excel pivot table where the data is 
“aggregated” or summarized.  For example, individual transactions are not included in a cube, but a total 
of expenses for a particular account would be included. The other style is a detail map which does include 
all transactions. Working with a detail map can be challenging and may cause performance issues, due to 
holding in some cases, millions of rows of data. 
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Edit Tab Workspace 
 

The Edit Tab is the SAS workspace that allows you to add, modify and delete report types, such as crosstabs, 
pie, or line charts. SAS offers 14 different report types that can be included in your report. Each report type is 
dragged into a cell in the grid. In this design space, all of the formatting, assigning data items, filtering, sorting 
etc. can be configured. 

 

1. Report Types 

2. Report Editing Tools 

3. Reporting Header 

4. Reporting Grid 

5. Reporting Footer 
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1. Report Types 

Report Type Icons 

 
 
A. List Report 
B. Crosstab 
C. Bar Chart 
D. Line Chart 
E. Bar and Line Chart 
F. Progressive Bar 
G. Scatter Plot 

H. Bubble Chart 
I. Pie Chart 
J. Tile Chart 
K. Geographical Map 
L. Text Box 
M. Image 
N. Stored Process 

 

  Insert Report Type - To insert a report style into the grid, click and drag the icon into desired 
quadrant. The reporting grid allows you to put several reports and/or charts on one page. In addition, 
list reports are not available when using a cube style map, as they require a detail map.   
 

2. Editing Icons  
 
A. Delete a report object  
B. Insert column before   
C. Insert column after 
D. Insert row above 
E. Insert row below 
F. Merge cells 
G. Split cells vertically 
H. Split cells horizontally 
I. Align left 
J. Align center 
K. Align right 
L. Alight top 
M. Align middle 
N. Align bottom 
O.  

  Editing Icons - Highlight the cell, row, column, or report object to activate 
 the icons and click the desired action. 

 

 

Report Editing Icons 



Enterprise Reporting and Training 

Page 6 of 23   (rev. 3/15/2024) 

3. Report Design Grid 
The reporting grid allows you to drag and drop report types into the grid, add, remove, merge and split 
columns and rows. This is your working design space. 

4. & 5.  Headers and Footers 

Click the drop down to enter Headers and Footers. Select images, text, fonts, colors, alignments, and 
insert dynamic text such as data source and description or modified date.  

 

A. The header can be set up in three sections indicated by the Tabs. The Middle content tab displays 
initially with a width of 100%, and the Left content and Right content tabs have no content and a 
width of 0%. Use the Width field to specify the percentage of space to use for each content area.  

B. Enter Header and set font styles here. 
 
C. Dynamic text acts a placeholder for text that will be generated from data when the report is 

viewed. You can include dynamic text in a header or a footer and mix it with static text. Dynamic 
text options include  Data Source, Data Source Description, Refresh Data, Report Author, Date 
Modified, Report Description and Report Name. 

 

  Note that the Date of Last Refresh indicates when you opened the report or selected “Data” and 
“Refresh” from the menu, so in effect, this is the current date and time stamp.  As a reminder, the 
majority of the data in SAS is refreshed the night before.  

  

Header and Footer Dialogue Window 
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Exercise 1 
In this exercise, we will drag three chart types into the design grid, align them as instructed, and enter a 
header and a footer using static text and dynamic data fields. 

 

1. Insert a new section and name it “SAS Intermediate Class Exercise”. Remember to “Copy data from” and 
select the report which contains the data you would like to use in your new report.  

2. Add a Pie Chart in the upper left quadrant of the grid.   
3. Center Align horizontally and Middle Align vertically the Pie Chart 
4. Add a Line Chart in the upper right quadrant of the grid 
5. Left Align horizontally and Middle Align Vertically the Line Chart 
6. Add a Crosstab in the lower left 
7. Merge the lower left and lower right cells together to allow the crosstab to use the entire width of the 

page 
8. Center Align and Middle Align the Crosstab 
9. Type a middle Header of your choice on the first line, insert the dynamic field – Date Modified on the second.  
10. Change the first line of the Header to 14 pt.  
11. Check the box to add a line between the Header and the body of the report 
12. Type a middle Footer of your choice on the first line, insert the dynamic fields Data Source Name and Report 

Author on the second line. 
13. Change the first line of the Footer to 14 pt.  
14. Check the box to add a line between the Footer and the body of the report 
15. View the Report 

Your report should look similar to this: 
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The Right Click Menu on Report Types 
 

As in other areas of SAS, the menu that displays when SAS is “right clicked” changes, depending upon what 
and where you click. For example, Pie and Line charts do not offer a “Totals” option like the Cross Tab style 
report does, because it isn’t an option for those charts. SAS menu’s offers options that are available in the 
current workspace. 

 

 

Commonly Used “Right-Click” Menu Options 
 

Assign Data 

The Assign Data window is accessible through the Right-Click 
menu on a report object.  It can be used from either the Edit tab 
or the View tab.  

The Assign Data window is where the data fields are assigned to 
the table or chart as columns, rows, pie slices, x-y axes, etc., 
depending upon the chart type.  

Click and drag to move fields to assign them, in and out of the 
various sections. Highlighting multiple rows by holding down the 
control key allows moving multiple fields at one time. 
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Filter and Rank – Setting criteria restricts the number of rows displayed in a table or chart. Ranking allows the 
ordering of the rows according to the value of a selected measure item.  

 

Example of a Filter and Rank Window 
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Conditional Highlighting – Conditional highlighting allows different formatting based upon a measure value. 
After selecting “New” to define a new rule, be sure to set the Rule, the Color and Font and/or the Image and 
Text settings as they all work together.  On the Image and Text tab, note that the checkbox to “Highlight by 
adding an image or text” must be checked in order to select settings on that window. 

 

Conditional Highlighting Tabs 

 
 

Remove [Report Type] – Delete the selected report. 

Data Source Details – Describes the data source selected for the current report. 

Properties – Set General defaults which vary based on chart type, as well as default fonts for Text and Totals 
throughout the report.  

 An interesting Property default to note is when looking at a crosstab or list report, SAS limits the number of 
columns or rows to display at one time by default. Choose Properties and select “Show all columns (up to 
system limit)” option to show more than 12 or “Show all rows (up to system limit)” to show more than 40 
rows.  SAS will prompt with a “Next Page” option at the bottom of the screen to scroll through additional 
pages. 
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Total – Select to set types of totals to display on the report. 

% Of Total – For unsynchronized tables, this option allows creation of an extra column which calculates the 
percent of total for a selected measure. 

 

Custom Calculated Fields 
 

Section Data – We’ve seen how the information map has many fields available to use for the current report. 
The Custom tab in the Section Data/Select Data menu allows creation of custom calculations. 

 Custom Calculations Window 

1. Navigate to the Custom Tab window 
a. Click the drop down in the Select Data panel  
b. Click Select Data 
c. Click the Custom tab 

2. Enter the name “OwlPay+PCard” 
3. Highlight the field you want in your equation 
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4. Use the Right Arrow icon to move the field into the Expression box. You also may choose to type the 
field name within square brackets. Your calculation will be built in the Expression box.  
 
 Items that may be used in expressions are: 

a. Measure names enclosed in square brackets, from the selected information map 
b. Parenthesis to perform calculations outside of the normal order of operations 
c. Addition (+), subtraction (-), multiplication (*) and division (/_ signs 
d. Numeric Constants 

 
5. Click or type the required operator  
 Repeat steps 4 - 6 as needed to build your equation.  
 

6. Click Add 
7. Click OK 

 

 

Synchronize all Tables and Charts 
 

To have all tables and charts change and filter together as 
you drill through the hierarchy, from the Edit tab, select 
“Synchronize Objects” from the Data menu. 
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Exercise 2  
In Exercise 2 we will explore some of the “right-click” menu options to fine-tune the report. You will 
primarily be working in the Edit Tab unless otherwise indicated. 

1. Pie Chart 
a. Select the Edit Tab and work in the design space unless otherwise indicated 
b. Right click on the chart and select Assign Data. Remove the default values and replace with the 

instructions below 
i. Assign the Segment Size to the measure Total Spend  

ii. Assign the Segments to Budget Account Type (it may default to this) 
iii. View the Pie Chart 

c. Properties 
i. From the General tab, Add a Title and change the font to be 14 pt. 

ii. From the General tab, Change the Chart Size to Fixed (this makes it manually adjustable) 
iii. Click the box to add a border and choose a color of your choice. 
iv. From the Pie tab, Make the Pie Three-dimensional 
v. From the Pie tab, Change the Labels text to Blue 

vi. From the Pie tab, click show data values 
vii. View the Pie Chart 

viii. Click on the edge of the border to drag and change the size 
 

2. Line Chart 
a. Select the Edit tab to navigate back to the Design Space 
b. From the Section Data panel on the left side, choose Select Data from the drop-down menu and 

add Accounting Month to the selected data items 
c. Right click on the line chart and select Assign Data. Remove the default values and replace with 

the instructions below 
i. Assign the Total Spend to the Line Height (Axis 1) 

ii. Add the Accounting Month to Line (Limit 1) and remove any other data items  
iii. View the Chart 

d. From the Edit Tab, right click and select Properties 
i. General Tab 

1. Add a Title and change the font to be 14 pt. 
2. Change the Chart Size to Fixed 
3. Add a border 

ii. Line Tab 
1. Change the line thickness to 4 pt. 
2. Change the Marker size to Medium 
3. Check “Show data values” 

iii. Axis Tab - Change the color of the labels 
iv. View the Chart 
v. Click on the edge of the border to drag and change the size 

3. Cross Tab 
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a. Assign data (remove the default values and replace with the instructions below) 
i. Assign the following Columns: Amended Budget, Total Spend, % Budget Spent 

ii. Assign the hierarchy for the Rows 
iii. Hide all other fields 

b. Totals – select to show Column totals 
c. Filter and Rank 

i. Set a filter to show one department of your choice. 
d. Properties 

i. Enter a title for the Cross Tab and change the font to be 14 pt. 
ii. General Tab – select Show all columns and rows 

iii. Text Tab 
1. Change headings to be 10 pt., bold, and Green 
2. Change subheadings to be 9 pt., bold and Blue 
3. Change cells to be 8 pt., and Purple 

iv. Totals Tab - Change the Totals to display in Blue and a 10 pt. font 
v. View the Cross Tab 

vi. Drill through the hierarchy to the bottom level (or to a level that has multiple rows to 
work with) 

vii. Identify a middle value in your % Budget Spent Column for Conditional Highlighting 
e. Conditional Highlighting 

i. This can be done from either the Edit or View Tab 
ii. Right click in the body of the report in the View tab, or on the report object in the Edit 

tab, and select Conditional Highlighting 
iii. Create a new rule by clicking on “New” 

1. Rule Tab 
a. Set the % Budget Spent to be Greater Than your selected value above. 

Note decimal values should be entered as .50 for 50%, for example. 
b. Ensure “All hierarchy levels” is selected 

2. Color and Font Tab - Change the Color and Font tab to a dark red background 
with a yellow font.  

3. Image and Text Tab –  
a. Check the “Highlight by add an image or text” box 
b. Select the Image radio button 
c. Select the position “To left of cell value” 
d. Select the yellow caution triangle as the image 

iv. View Report 
4. BONUS QUESTION – Create a calculated field of your choice. What happened to your cross tab?  

  Notice in the Table of Contents drop down menu that your new report shows at the bottom. 

 

Your report should look similar to this: 
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Just for fun, from either Edit or View Tabs, choose View from the Menu, Report Style, and pick one to change the color 
theme of the reports!  
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Managing The Table of Contents 
 

The options menu for the Table of Contents panel allows you to manage your reports. 

 

 

1. Insert a New Section – this opens up the reporting design workspace 
2. Delete Section (Caution! There is no “undo” to get it back – unless you have saved a copy) 
3. Rename Section – Change the name of the report 
4. Copy Section – Makes a copy of a report  
5. Reorder Sections – Reorder the report list 
6. Group Breaks – Breaks a report into sections like years or Divisions.  
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Group Breaks 
 

Group Breaks are a way to break up the view into manageable portions of data.  When you insert a Group 
Break, it lists the contents of the field in the Table of Contents window (upper left panel) so that you can easily 
click to change your view.  For example, a Group Break set to the Department field would display a list of 
departments in the Table of Contents window. Other fields that are useful to use as a Group Break would be 
Projects or historical Fiscal Years. 

  Sometimes it is helpful to remove Group Breaks from existing reports. However, use caution because 
removing the Group Break could cause large numbers of rows to be returned with the potential to decrease 
system performance. 

 

Add a Group Break 
 

 

 

D. Select Data from the menu in the Edit tab 
E. Select Edit Group Breaks … 
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1. Select a data item to break by 
2. Choose to display the data item in ascending or descending order 
3. Check New page for each value to split the report into pages 
4. Optional: Select a subgrouping to further split the data 
5. Choose to display the data item in ascending or descending order 
6. Choose the formats to show the Group Break Values which appear at the top of each page 
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  Notice that setting a group break adds additional information under the Header of the report.  The red 
boxes are outlining the Division and Department above the charts, indicating they are breaking on those 
items. 
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Remove a Group Break 
 
Select: “None” in the Group Break Window 
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Saving a Report  

You may customize reports with your preferred selections and can save it in your personal folder named “My 
Folder” or save it into your shared Department Folder to share with others.  These reports will also be refreshed 
nightly. 

a. Select File from the menu in the upper left corner of the screen  

b. Select Save or Save As to open the dialogue window 
 

Save to your “My Folder” (your personal folder) 

a. Enter a new file name. 

b. Click the drop-down arrow to see folders and choose “My Folder” to save the report in your 
personal folder if it is not already selected. 
 

 
Save to a Division or Department Folder 
 
If you have permission, you may save to a shared folder so that more than one person can use the report.  Note 
that this also means that others will be able to open, use, edit and save over this report! You may want to keep 
a copy in your personal folder as a backup. 
 

c. Enter a new file name.  

d. Click the drop-down arrow and choose SAS Folders to go up one level from “My Folder” in the folder 
tree. 

e. Navigate to this path:  SAS Folders/Reports/Financial/Custom/ [Your Division or Department] 

f. Click OK. 
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Manage Files 
 
To Manage your files and perform actions such as Move, Copy, Delete or Rename 
 

1. Select File from the menu in the upper left corner. 

2. Select Manage Files. 

3. Click the report that you want to Move, Copy, Delete or Rename. 

4. Choose the Action from the Action Menu. 
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Two Methods to Open an Existing Report  
 
1. From the SAS Portal - Financial 
 

a. Select Financial in the left menu panel. 

b. Choose an existing Financial Report from the Financial Portlet. 

 
2. From SAS Portal - Getting Started 
 

a. Choose “Getting Started” from left menu panel in the Portal 

b. Select SAS Web Report Studio from the top right corner in the Portal 

c. This first dialog box provides a short cut to your recently accessed reports.  

d. Or select “More Reports” to navigate through the SAS Folders to locate your desired report. 
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